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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

* Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

» Bold type is used for the following:

o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

° On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign > Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter’ means to

press the key labeled Enter.
« |talic type is used for the following:

° Emphasis.

° The titles of publications.

o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

* The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key

or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

« The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"

@ Al
O L.
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

* The menu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the File menu, click the Open Examples command" means you can click the File
menu and then click Open Examples to launch the dialog box.

* Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation > Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu
To access help from the Help menu, click Help and select from the menu:
« [product name] Help - opens the contents of the help. This help includes the help for the
product and its Getting Started Guides.
* [product name] Scripting Help - opens the contents of the Scripting Guide.

* [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction

In this project, you will perform a transient analysis of a Ball Grid Array (BGA) IC package. You
will visualize the propagation of a short pulse by creating a transient plot of Y1 vs. Time, create a
transient plot of the residual, obtain S-parameters over a broad frequency range, and view an
overlay of the transient E-fields.

The geometry corresponds to a portion of a BGA-type chip package. The model has four signal
lines as well as power and ground nets.

Network Analysis

You can perform a network analysis in both the frequency domain and the time domain (transient
analysis). In addition to obtaining the familiar S-parameters, you can perform the analysis in the
time domain to visualize the propagation of a short pulse through a device. You will do so in this
exercise.

Sample Project: BGA IC Package

The model is installed with the Ansys Electronics Desktop application, and it is located in a sub-
folder within the Help branch of the installation path.

The geometry is complete — no additions or modifications are needed. However, you will apply
the excitations, set up and run the analysis, and generate the reports and field overlay.

Figure 1-1: BGA IC Package Geometry

Introduction 1-1
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2 - Set Up the Model

This chapter contains the following topics:
Open the Model
Verify Solution Type

Review Boundaries

Assign Excitations

Open the Model

Begin with Ansys Electronics Desktop launched but no project open.

- |

1. Onthe Desktop ribbon tab, click ——& Open Examples. Then:
a. Inthe Open dialog box that appears, click the parent folder icon (1) once to move
up one level above the Examples folder.

b. Double-click the Help folder and then the HFSS folder.
c. Selectthe file Alinks_BGA.aedt and click Open.

Note:

The project is deliberately incomplete. You need to add excitations and a solution
setup to analyze the model and perform post processing. For this reason, the pro-
ject file is located in the Help folder instead of the Examples folder.

2. On the Desktop ribbon tab, click H Save As.

3. Navigate to a working folder of your choice (you can't write to the program installation
path) and click Save to place a copy of the model in your working folder using the same
file name.

Verify Solution Type

1. Under Alinks_BGA in the Project Manager, right-click HFSSModel1 (Transient Network)
and choose Solution Type from the short-cut menu.

The Solution Type dialog box appears.

2. Ensure that the settings are as shown in the following figure and then click OK:

Set Up the Model 2-1
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Solution Type: Projectl - HF35Design =

Solution Types
" HF55
{7 HFSS with Hybrid and Arrays
{* Tranzient
" SBR+
" Eigenmode
£ Characteristic Mode

Optians

i Metwork Analpsis ¢ Composite Escitation

{ {+

[ Auto-Open Region

| Save az default

] | Cancel

Figure 2-1: Solution Type

Review Boundaries

Two boundary conditions have already been defined:

1. Select each item under Boundaries in the Project Manager to see where the boundary con-
ditions are assigned.

- EF Boundaries
¥ FadiationBoundary
¥ ReferencePlanes

Figure 2-2: Boundaries

Set Up the Model 2-2
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RadiationBoundary

The radiation boundary is applied to all outer faces of an air volume that surrounds the model.
Fields are calculated inside the air volume, which is large enough for an accurate signal-integrity
simulation. You will not determine the radiated fields for this exercise.

Figure 2-3: RadiationBoundary

ReferencePlanes Boundary:

The ReferencePlanes boundary is a Perfect E boundary applied to two faces of the BGA model.
These planes provide references ("ground") to the ports. Since the power and ground nets are
also connected to these planes, each signal current has a return path. This configuration is
necessary for a meaningful simulation.

Set Up the Model 2-3
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Figure 2-4: ReferencePlanes Boundary

Available Boundary Conditions

Take a few moments to see what other boundary conditions are available in HFSS Transient
analyses:

2. Right-click in the Modeler window and point to Assign Boundary, but do not make a
selection.

Boundaries that are unavailable (grayed out) are sometimes frequency-dependent (such
as Coupled > Primary and Secondary) and are not straightforward to implement in the

time domain.

Set Up the Model 2-4
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Group »
Create 30 Component...

Replace with 3D Compeonent...

I ]

Assign Material...

Create Array ...

Create Open Region ...
Update Open Region Padding...

Assign Boundary ¥ Anisotropic Impedance...

Assign Excitation » Aperture...

Assign Mesh Operation » Coupled... % H Lattice Pair...

Plat Fields - Finite Conductivity... | Primary...
Fresnel (SBR+) Secondary....

Plot Mesh. Half Space...

Auto |dentify lattice pair...

Plot VRT * Impedance... ‘
Layered Impedance... \

Plot Particles...

Linked Impedance...
Lumped RLC...
Multipaction SEE...
Perfect E... Shift+E
Perfect H...
Radiation... Shift+X

Copy Image

Symmetry...

PML Setup Wizard...

Figure 2-5: Boundaries shortcut menu

3. Click in the Modeler window background area to cancel and close the shortcut menu.

Assign Excitations

In this section you will assign excitations to all the sheet objects that appear under Unassigned
in the History Tree.
1. Inthe History Tree, expand Model, Sheets, and Unassigned.

2. Right-click the first unassigned sheet object LNK_12_BW and choose Assign
Excitation > Port > Terminal Lumped Port from the short-cut menu.

Set Up the Model 2-5
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-3 Sheets
(-3 Perfect B
£ Unassigned
Rl LNK 12 B0
A LNK, Expand All

[H-E0 PAR Collapse All
&0 PAR
F-E TXCl Select b
BB TXCE >
H-E TXD A
ETD T - T~ B ! =
|2, Coordinate Sys , \
& Planes Assign Boundary »
& Lists Assign Excitation ¥ Port ) Circuit Port...
Assign Mesh Operation » Incident Wave ¥ Floquet Port...
Plat Fields ) Current... Modal Lumped Port...
Voltage... Modal Wave Port...
Plot Mesh... i : .
o Linked Field » Terminal Lurnped Port..EP
Plat VRT » Magnetic Bias.. Terminal Wave Port...
Plot Particles Multipaction Charge Region..

Terminal...
Multipaction DC Bias...

RF r" arg

Figure 2-6: Assign Lumped Port Excitation
The Reference Conductors for Terminals dialog box appears.

3. Forthe Conductor BONDWIRE_REFPLANE_1, select the Use as Reference option.

Keep the default Port Name, ensure that all other settings are as shown in the following fig-
ure.
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B | Reference Conductors for Terminals )4

Port M ame:; 1
Terminal Maming
* |lze conductar narme

" Use port object name

MOTE: Multiple reference conductors touching a
port muszt all be connected in the plane of the part.

Conductar Ilze az Reference

. EONDWIRE_REFFLANE 1

Figure 2-7: Reference Conductors for Terminals (Port 1)
4. Click OK.

LNK_12_BW moves from the Model > Sheets > Unassigned branch of the History Tree to
a new Lumped Port branch. Therefore, the first item now listed under Unassigned is the
one to which you will assign the second lumped port.

5. Similarly, select the remaining objects under Unassigned in the History Tree one by one
and assign a terminal lumped port to each of them.

Note:

For every object, the conductor that has the reference plane 1 boundary asso-
ciated with it (...REFPLANE 1) should be set to Use as Reference. The High-
light selected conductors option at the bottom of the dialog box is selected by
default.

Set Up the Model 2-7
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B | Reference Conductors for Terminals )4

Port M ame: 8
Terminal Maming

* |lze conductar narme

" Use port object name

MOTE: Multiple reference conductors touching a
port muszt all be connected in the plane of the part.

Conductar Ilze az Reference
SOLDERBALLREFPLAME 1

. T#D 12 0__DLL_LTC_shal -

Figure 2-8: Reference Conductors for Terminals (Port 8)

6. One by one, select each port (7 through 8) listed under Excitations in the Project Manager
and do the following in the docked Properties window:

¢ Deselect the Renorm All Terminals option:

Properties o x
Name | Value | Linit | Evaluated
Name 1
Type Lumped Part
Active [w
Impedance 80 ohm H0ahm
Num Terminals 1
Deembed [
Renarm All Teminals [ —

Figure 2-9: Lumped Port Properties (Port 1)
This action prevents port renormalization when post processing.

7. Right-click Excitation in the Project Manager and select Auto-Assign Terminals from
the short-cut menu.

Set Up the Model 2-8
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--ﬁ’ Boundaries

o (2

-6 1 Assign

@ 2 Auto Assign Terminals I}
@ 3 Set Default Base Mame

@ . Edit Port Impedance Multiplier
@ 5 Edit Sources...

B 7 List...

GROE Delete All

Figure 2-10: Selecting Auto Assign Terminals
The Reference Conductors for Terminals dialog box appears.
8. Edit the settings as shown in following figure and then click OK.

Terminal Maming

{* Uze conductor name

" Usze port object name

HOTE: Multiple reference conductors touching a
part muzt all be connected in the plane af the part.

Conductor | Ilze az Reference
BOMDwIRE_REFPLAME 1 [v
LHK_12_bwire

LMK _12_zhall
FART_FREE_INIT _bwire
FPART_FREE_IMIT_zball
SOLDERBALLREFPLAME_1
THCLE_12_bwire
TeCLk_12_sball
TeD_12_0__DLL_LTC_ bwire
TeD_12.0_ DLL_LTC_sball

B A A A R 1 1

Figure 2-11: Reference Conductors for Terminals (All Ports)

Take a few moments to see what other excitations are available in HFSS Transient analyses.
9. Right-click in the Modeler window and point to Assign Excitation in the shortcut menu.

The list of available excitations appears. The items in gray text are unavailable:

Set Up the Model 2-9
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Mext Behind E

Selection Mode ¥
Select Objects *
Extend Selection »

Go to History

Measure »
View »
Edit »
Group *

Create 30 Compenent...
Replace with 30 Component...

L

Assign Material...

Create Array ...

Create Open Region ...
Update Open Region Padding...

Assign Boundary -]
Assign Excitation » Port \
Assign Mesh Operation ¥ Incident Wave b Plane Wave...
Plot Fields 3 Current... I/\\s Hertzian-Dipole Wave...
Voltage... Cylindrical Wave...
PlotMesh... Linked Field » Gaussian Beam...
Plot VRT 4 Magnetic Bias... Linear Antenna Wave...
Plot Particles... Multipaction Charge Region...
Multipaction DC Bias...
Copy Image

RF Discharge DC Bias...

We are not targeting certain applications: Unit cells of periodic structures (phased arrays,
FSS) or models with magnetic bias (ferrite circulators, ferrite phase shifters). HFSS
handles these applications better in the frequency domain.

Set Up the Model 2-10
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Note:

You can see that only the Plane Wave excitation is available under Incident
Wave. If you expand the Linked Field branch, you will see that none of these
excitations are currently available.

10. Click in the background to cancel the shortcut menu.

Set Up the Model 2-11
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3 - Analyze the Model

This chapter contains the following topics:
» Create Face List for Field Saving
» Settings in the Solution Setup
¢ Run Simulation
* Generate Reports
» Matrix Post Processing
» Fields Post Processing
¢ How to Set up HPC Integration

Create Face List for Field Saving

First define a face list that includes the faces where fields are to be saved. To make selection of
the appropriate faces easier, you can hide the air_box and DIELECTRIC objects.
1. Under Model > Solids > air in the History Tree, select air_box.

2. Hold down the Ctrl key and, under Model > Solids > FR4_epoxy_lossless in the History
Tree, also select DIELECTRIC.

3. Onthe Draw ribbon tab, click & Hide selected objects in active view.
The two objects are hidden, and they can remain hidden throughout the remainder of this
getting started exercise.

4. Press the F hotkey to begin the face-selection mode.

5. Select the top surfaces of both the power and the ground plane, as shown in the following
figure. (Rotate the model view and zoom in as needed for a clear view of the two faces.)

Analyze the Model 3-1
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==

Figure 3-1: Power and Ground Planes Selected

6. Using the menu bar, click Modeler > List > Create > Face List.
7. Under Lists in the History Tree, select FaceList1.

The list settings appear in the docked Properties window.

8. Change the Name from Facelist1 to PlotFields and press Enter.

9. If you zoomed in when selecting the faces, and part of the model extends beyond the lim-
its of the display area, do the following:

On the Draw ribbon tab, click @, Fit ANl (or press Ctrl+D) to fit the model to the display
area.

Add Solution Setup

1. On the Simulation ribbon tab, click & Setup (Add solution setup).

2. Inthe General tab of the Transient Solution Setup dialog box that appears, ensure that
the settings are as shown in following figure:

Analyze the Model 3-2
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Transient Solution Setup

Input Signal ] Duration ] Saved Fields ] Radiated Fields ] Defaults ]

Setup Mame: ==

lv Enabled
Mesh Impart

[ Import Mesh |

Adaptive Solutions

Maximum Mumber of Passes: |2E'

Maximum Delta 5:  |0.02

Transient Saolver
Use: 1 Hybrid Solver

* |mplicit Solver

lIse Defaults

HPC and Analysis Options. .. ‘

QK | Cancel

Figure 3-2: Transient Solution Setup — General Settings

Note:

HFSS Transient automatically sets parameters for determining the mesh, such
as the use of mixed element orders and the iterative solver in the frequency
domain. The frequency at which the mesh is automatically adapted is based on

the time profile you specify next.

3. Select the Input Signal tab and edit the settings as shown in the following figure:

Analyze the Model 3-3
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Transient Solution Setup X
General Duratiu:un] Saved Fields | Radiated FiE-'|l:|Sl Defaults]
Profile
Function: |Bn:uau:||:uanu:| Pulse j Min Freq: |0 ||"-"|sz
Frequencies extracted: 1001 Max Freq: |'II3.I |GHzﬂ
1.00
= 7
& 0.50 —
i -
0.00 |||||||||||||||||||||||||||||||||||||||
0.00 0.25 0.50 0.75 1.00 1.25 1.50 1.75 2.00
Time [ns]
1.00
E 7
E 0.50 —:
[iF] -
{I_{I{I||||||||||||||||||||||||
0.00 2.00 4.00 6.00 8.00 10.00
Frequency [GHz]
QK | Cancel

Figure 3-3: Input Signal Settings

The result will resemble that of an interpolating frequency sweep with the same spe-
cifications.

Note:

For more information, see Settings in the Solution Setup .

4. Select the Duration tab and specify the settings shown in the following figure:

Analyze the Model 3-4
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General | Input Signal Saved Fields ] Radiated Fields ] Defaults ]

% Auto Terminate Target Residual |60 dB
¥ At most 125 |ns |
[ Atleast 100 s ~|
" Stop at time 2 ns |

Figure 3-4: Duration Settings

Note:

The simulation will run until transient fields have mostly died out, determined by
the Target Residual. Additionally, a maximum simulated time is determined by
the equation:

20 x (model size) / (speed of light).

In this case, you are setting an extra limitation on the duration. Considering the length of
the traces, in one nanosecond, the signal can travel from source to termination and back
several times. It is therefore reasonable to limit the simulated time to at most 1.25 ns,
being the aforementioned 1 ns plus the duration of the input signal.

. Select the Saved Fields tab, specify the settings shown in the following figure, and then
click OK.

Analyze the Model 3-5
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General ] Input Signal ] Duration | Saved Fields | Radiated Fields ] Defaults ]

% PlotFields
Transient fields will be calculated for the
selected Object Lists and Face Lists.
Lists are created in the modeler.
| Star saving fields at: |i g J
[+ Savefields eveny: |4 |ps ﬂ

[ Madmum Number of Samples: 256

Figure 3-5: Save Fields Settings

Note:

4 ps is somewhat arbitrary. In 4 ps, the signal travels 0.6 mm in dielectric, so this
sampling rate should provide a smooth animation for this model.

Settings in the Solution Setup

You can create a time-domain profile by specifying minimum and maximum frequencies. If you
specify zero for the lower bound, the pulse shape changes and will really include frequencies all
the way down to DC. In addition to the sweep, a TDR pulse can be defined. This pulse is the
same as the sweep from DC to a certain maximum frequency, but, for your convenience, it is spe-
cified by rise time.

Finally, note that you must specify the profile only once for all active excitations. In the more gen-
eral Transient (“non Network Analysis”) design, you can specify different time profiles for dif-
ferent excitations and run one simulation with all active excitations turned on simultaneously. In
Transient Network Analysis, all active excitations get the same time profile one by one, and you
get one simulation per active excitation. This method is the proper way to characterize a net-
work.

Analyze the Model 3-6
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Set Up HPC Options and Run Simulation

The simulation will take about 400 MB of memory per excitation. If you have all ports active we
recommend you distribute the simulation if possible. In a distributed simulation, with at least
eight processors and with enough RAM, each one of the eight excitations gets its own process,
and they will all solve simultaneously.

Assuming your workstation has at least eight processing cores, you will set up the high-per-
formance computing (HPC) options to take advantage of them.

E[3
1. On the Simulation ribbon tab, click - £2 HPC Options.

The HPC and Analysis Options dialog box appears.
2. Ensure that HFSS is selected in the Design Type drop-down menu and then click Add.

Corfigurations l Options ]

Design Type: |@ HFsS j

Figure 3-6: Design Type for HPC Setup
The Analysis Configuration dialog box appears.

3. Inthe Configuration Name text box, type Eight Cores.

4. Ensure that the following two options are selected and then click Add Machine to List:
» Use Automatic Settings
* Local Machine (under Machine Details)

The localhost entry is added to the Machines for Distributed Analysis list.

5. Setthe localhost values for Cores and RAM Limit (%) as shown in the following figure.
The red numbers correspond to the step numbers in this procedure.
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B Analysis Configuration x

Configuration name: |EightCn:|res — 3

[¥ Use Automatic Settings
Mum variations to distribute: | 1 3:
Machines lOp‘tigng ]

Machines for Distibuted Analysis
Total Enabled Cores: 8, GPLU is enabled with SBR+ solve only

Name | Cores | GPUs | RAM Limit (%) | Enabled
localhost 8 1 50 [w

I

Machine Details:

* | ocal machine

" |P Address format: 192.168.1.2): |

" DNS Mame format: www server.com): |

" LUNC Mame format: “iserver): |

4
\ Add Machine to List

Import Machines from File ... |

Figure 3-7: HPC Analysis Configuration for localhost

6. Click OK.
7. With the Eight Cores configuration selected, click Make Active.

The HPC and Analysis Options dialog box should now match the following figure:
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B HPC and Analysis Options et

Corfigurations ] Options ]

Design Type: |@ HF55 j
Awvailable Configurations: Corfiguration Details:
Active | Mame | Total Tasks | Make Active | Configuration Name:

Eight Cores (Auto)
Add. Machine List:
Edit_ localhost (Auto):8: 900

Job Distribution:

ﬂ EEEEEE=E======E==E
Dptimetrics varations will be solved sequentially.

Cther distribution types will be distributed
Copy... automatically.

Import... AllowOffCore - True
Export...

Click OK to accept the configuration and close the dialog box.

H Save the project. (This command is available from all ribbon tabs).

On the Simulation ribbon tab, click ek Analyze All.

HFSS first performs the frequency-domain adaptive passes, after which it completes the
eight transient simulations, one per excitation.
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4 - Generate Reports

You can generate reports while the simulation is running, though the completed traces won't plot
until the solution is finished. Data is plotted as it becomes available from the solver.

You can keep track of input signals, outputs on the various ports, and field residuals as the sim-
ulation is progressing. You can generate both time-domain (transient) and frequency-domain
plots.

In this section, you will create three transient plots (results versus time) and one plot of results
versus frequency, as follows:

+ Input Pulse and Response: Transient plot of input pulse at port 1 and output response
atports 5and 6
* Residual: Transient plot of residual at port 6

+ E-Fields Overlay: Transient E-field overlay displayed on two previously designated
model faces (power and ground plane)

+ S-Parameters vs. Frequency: Specifically, S(6,5) and S(6,6)

In each case, you will select the appropriate terminal names in the Report dialog box when defin-
ing the plots (and not the simple lumped port excitation numbers shown in the preceding bullet
list).

Input Pulse and Response

The first of three transient plots you will create consists of the following three traces vs. Time (in
nanoseconds):

e Input(LNK_12_bwire_T1) (lumped port 1)
e Output(TXCLK_12_bwire_T1) (lumped port 5)
e Output(TXCLK_12_sball_T1) (lumped port 6)

Create the plot as follows:

*\/"?f

(—( '{-\".,I'III
1. On the Results ribbon tab, click ' | Terminal Solution Data Report>|__V —__| 2D.
2. Inthe Report dialog box that appears, specify the following settings:

a. Ensure that Setup1 : Transient is selected from the Solution drop-down menu
and Time from the Primary Sweep drop-down menu.

Context Trace l Families ] Families Display ]

Primary Sweep: [Time - |.-5.II

Figure 4-1: Solution and Primary Sweep Settings (Transient)

Solution: |5et|_||:|1 : Transient j
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b. Select Transientin the Category list.
c. Selectthe following three items in the Quantity list:
¢ Input(LNK_12bwire_T1)
e Output(TXCLK_12bwire_T1,LNK_12_bwire_T1)
e Output(TXCLK_12sball_T1,LNK_12_bwire_T1)
d. Select <none> in the Function list.

X: v Default | Time J

¥ |In|:nut(LNK_12_|:nwire_T1]|; Output(TXCLK_12_bwire_T1,LMK_12_bwire_T1); Output{TXCLK EEQE;DH

Category: Quantity: | j Function:

Variables Input{LME_12_bwire_T1)

E%WES_ Input{LMK_12_sbal T1) abs

Desion Input(PART _FREE_INIT bwire T1) :Eg:h
Input{PART_FREE_IMIT sball _T1) ang_deg
Input{TXCLK_12_bwire_T1) ang_deg_val
Input(TXCLK_12_sball_T1) ang_rad
Input(T¥D_12_0_ DLL_LTC_bwire_T1) :;IE'I_I
Input(T¥D_12_0_ DLL_LTC_sball_T1) —sinh
Output(LMK_12_bwire_T1,LMK_12_bwire_T1) atan
Output{LNK_12_shall_T1,LNK_12_bwire_T1) atanh
Output{PART_FREE_INIT bwire_T1,LMNK_12_bwir EDSh
Output(PART _FREE_INIT shall T1,LNK_12_bwire o nteq
Output{TXCLK_12_bwire_T1,LNK_12_bwire_T1) cum_sum
Output{TXCLK_12_sball_T1,LMK_12_bwire_T1) dB
Output(T¥D_12_0_ DLL_LTC_bwire_T1,LNK_12 dB 10normalize
Output(T¥D_12_0_ DLL_LTC_shal_T1,LNK_12_br ﬂEfE'”':'rmE'"ZE

Figure 4-2: Transient Plot 1 Trace Settings
3. Click New Report but leave the dialog box open for creating the next plot.

Transient Plot 1 appears in a new window. (Move the Report dialog box to the side or
move the plot window for an unobstructed view.)
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TI’EII"ISIEFIt P|Clt 1 HFSSModell Ansys
2023 R1
1.0 ﬁ
| ——  INput{LNK_12_bwire_T1)
- Setupl ; Transient
08 -
i Output{TXCLK_12_bwire_T1 LMK_12_bwire_T1)
i Setup? : Transient
06 __ = QutpubiTAXCLK_12_shall_T1 LMK_12_kbwire_T1)
- Setupl : Transient
Z 04 -
= N
0.2
0.0 — ————
'D 2 T T T T | T T T T | T T T T | T T T T | T T T T | T T T T | T T T T
0.0 0z 0.4 06 0.8 1.0 1.2 1.4
Time [ns]
Figure 4-3: Input Pulse and Response vs. Time
Residual

The Residual is a measure of the maximum field remaining anywhere in the model. It is used as
a stopping criterion under the Duration tab of the Transient Solution Setup dialog box. By

default, when the peak field has fallen to 0.001 times its maximum, the simulation is considered
complete. An example of a Residual plot with a logarithmic vertical scale is shown below. Mon-
itoring a plot like this during the simulation gives an idea of how much longer the simulation might
take. The progress bar gives complementary information; it is based on the maximum simulated
time. The residual doesn’t go down to -60 dB since the specified settings stopped the simulation
early.

You will plot the residual quantity at lumped port 6 using the dB20 function (20 time the base 10
logarithm of the quantity).
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The Report dialog box should still be open from the previous plot creation. If not, repeat step 1 of
the previous topic before proceeding to the steps below.

1. Keeping the Solution setting as itis (Setup1 : Transient), specify the Trace tab settings for
the Residual plot as shown in the following figure:

Trace l Families ] Families Displa'_.r]

Primary Sweep: |TIIT|E ﬂ |-"-|| J
X [+ Default |'I'|me J
- ; Range

y:  |dB20(Residual(TXCLK_12_shall_T1)) Fonceor..

Category: Quanﬁty:| filter-text Function:

Variables Residual(LMK_12_sball_T1) - |sinh o~

Output Variables Residual(PART_FREE_IMIT bw sqr

Transimt Residual(PART_FREE_IMIT shz sqrt

Design Residual(TXCLE_12 bwire T1 tan
Residual(TXCLK 12 shall T1 tanh

Residual(TXD_12_0_ DLL_LTC | |y0
Residual(TXD_12_0_ DLL_LTC, ~
4 [ 3

Mew Report | |

Figure 4-4: Residual Plot Settings
2. Click New Report and then click Close.
HFSS generates the Residual plot:

Generate Reports 4-4
Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: Ball Grid Array IC Package

Transient Plot 2

HFSSModell Ansys
2023 R1

0.0
i — B20(Residual{TXCLK_12_sbal _T1))
Setupl : Transient
= i
T 125
w1
o i
htd i
—
g
™
i} -
=
wl
x -25.0
=1
] i
[N
=
'3?5 T T T T | T T T T | T T T T T T T T T
0.00 0.25 0.50 0.75 1.00 1.25

Time [ns]

Figure 4-5: Residual Plot

E-Fields Overlay

To overlay the transient E-fields on the previously designated faces of the model, do the fol-

lowing:

1. Return to the Modeler window. (You can click in the window's title bar if it is visible or bring

it back to the foreground using the Window menu.)
2. Under Lists in the Modeler Tree, select PlotFields.
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=l Model
-7 Solids
-4 air
-4 copper
g FR4_epoxy_lossless
! gold
-4 solder
E- Sheets
I:I Lumped Port
I:I PerfectE
-1, Coordinate Systerns
&% Planes
=5 Lists
@D AllObjects

B «—

Figure 4-6: Selecting the PlotFields Face List

In the Project Manager, right-click Field Overlays and choose Plot Fields > E_t > Mag
E_t from the shortcut menu.

The Create Field Plot dialog box appears.

Under Intrinsic Variables, select a Time from the drop-down menu (for example, 500ps).
Keep the other settings at their defaults.

[ Specify Mame |MEIEI_E_H Fields Calculator ... |
[ Specify Folder |E Field J Categary: |Standard j
Design: HFSSkaodell [uantity I M alume
Contest :
GND_bwire -
Solution: |S|3|:|_,|p'| * Tranzient j l"."IEE'ZEI[_E_': GND_bWi[EE
b ag_H_t GMHD_wig_2
YWector_H_t GHD_wia_3 =
Field Type: | Fields | b ag_Jsurf_t GMD_4
Wector_Jsurf_t GHD_&

Yector_FealPoynting_t GMD_E
Yolume_Lozs_Denzity_t GHD_&

. LMK_12_bwire

Time |500ps -] LNE 12 shall
LME_12_wvia_2
LME_12_3

LME_12 4
PaRT_FREE_IMIT b
PART_FREE_IMIT st _

DADT COCC IMIT ou

=

| ntrinzic Y anables

Save Az Default |

[ S l
Done Cancel feamine
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5.

6.
7.

11.
12.

Figure 4-7: Field Plot Settings
Click Done.

The field overlay and legend appear in the Modeler window.

On the Draw ribbon tab, click H# Grid to toggle off the grid visibility.

As desired, middle-click and drag the mouse to rotate the viewpoint, Ctrl + middle-click
and drag to pan, and/or roll the mouse wheel to zoom in or out for a good model view-
point.

The field overlay should resemble the following figure:

E Field Ansys
[Vim] 2023 R1
Max: 893.121

800
I 810

720

B30

540

450

360

270

180
I a0

0
Min: 0.001

Figure 4-8: E-Field Overlay — Power Plane View (Time = 500ps)

Rotate, zoom, and pan the model again, this time for a good view of the bottom face.
Double-click within the E Field legend to access plot color and scaling options.

. On the Scale tab, make the following changes:

a. Select the Use Limits option.

b. Inthe Max text box, type 400.
On the Plots tab, select Gourard from the IsoValType drop-down menu.
Click Close.
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The plot should now resemble the following figure:

i Ansys
E Field 2023 R1

[VIm]
Max: 400.000

400,000
.BBD.DUD
320.000

260.000
240.000
200.001
160.001
120.001
80.001
40.001
0.001
Min: 0.001

Figure 4-9: E-Field Overlay — Ground Plane View (Time = 500ps)

13. Under Field Overlays > E Field in the Project Manager, right-click Mag_E_t1 and choose
Animate.

14. Specify the following settings in the Create Animation Setup dialog box that appears:
a. Inthe Description text box, type Late-Time Plane Resonances.
b. Inthe Start text box, type 560ps.

c. Inthe Steps text box, type 80. (This setting will produce animation frames withing
the specified time range at every other time step that was calculated.)
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MNarme: |.f.‘-.nimati|:.n1 Dezcription: |Late-Time Flane Aesonances
Swept Variable(s) | Design Point |

ISingIe variable j ITiI'I'IE.' ;I

Start: IED[bs
Stop: |1 240ps
Steps: IE'D

Figure 4-10: Field Animation Setup
15. Click OK.

There will be a delay while the animation frames are computed, and then the Animation
dialog box will appear and the overlay animation will start playing.

16. Use the available animation controls to pause, restart, reverse, or change the speed of the
animation.

E Field
[Vim]

Max: 400.000

.4[][].[][][]

360.000
320.000
280.000
240.000
200.001
160.001
120.001

80.001 Time = 600ps I

40.001

0.001
Min:  0.001

Figure 4-11: E-Field Animation
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17. Inthe Animation dialog box, click Close when you're done viewing the animation.

S-Parameters vs. Frequency

M
1. On the Results ribbon tab, click (_( Terminal Solution Data Report > | V| 2D.

The Report dialog box appears.
2. Inthe Context area, choose Setup1 : Spectral from the Solution drop-down menu.

This change enables you to plot frequency-domain S-parameters generated by the tran-
sient simulation. Notice that the Primary Sweep setting has changed from Time to Freq.

Note:

Even while a simulation is still running, the transient solver can give you fre-
quency-domain S-parameters based on the transient information it has gathered
thus far. The plot will be updated frequently. This process can slow down the
overall simulation, since every update requires transformations from time domain
to frequency domain. Of course, at this point, the Ball Grid Array simulation has
already been completed.

3. Make the Category, Quantity, and Function selections shown in the following figure:
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Trace l Families ] Families Display ]

Primary Sweep: |FFEE| j |-¢'-" J
X v Default |FI'EIZ| J
¥ |dB[5ttmcu<._12_s|:.a||_T1,Tx-::LK_12_|:.wire_T1}}; dB(St(THCLK_12_sbal_T1,THCLK_12_sbal_T 1)) EEQEEDH |
Category: Quantity: | j Function:
Variables St{PART_FREE_INIT shal_T1,TXCLK_12_bwire_T1) A |<nonex
'-'t FE":"ES - SHTHCLE_12_bwire_T1,TXCLK_12_bwire_T1) E""EI-SEEI |
TI F, SHTXCLE_12_sball_T1,TXCLK_12_bwire_T1) zﬂg—rffl'—”a
Terminal 7 Parameter StI:T?(D_IE_D_DLL_LTC_bWiFE_Ter?{CLK_IZ_bWirE_TIII arg -
Terminal VSWR St{TXD_12_0__DLL_LTC_sbal_T1,TXCLK_12_bwire_T1) cang_deg
Terminal Port Zo SH{LMNK_12_bwire_T1,TKCLK_12 shal T1) cang_deg_val
E:E"ne'j Terminal 5 Parameter SHLNK_12_sbal_T1,TXCLK_12_sbal_T1) cang rad
SHPART_FREE_INIT bwire_T1,TXCLK_12_shall_T1) B 10normalize
St{PART_FREE_INIT _sball_T1,TXCLK_12_sball _T1) dE20narmalize
SHTHCLE_12_bwire_T1,THCLE_12_shall_T1) dBc
SH(TXCLK_12 shal_T1,TXCLK_12_shall_T1) 'r;”a
SHTXD_12_0_ DLL_LTC_ bwire_T1,TXCLK_12 shal _T1) mr?_nahze
SHTYD_12_0_ DLL_ITC_sbal_T1,TXCLK_12 shal _T1) v |re
< >
Figure 4-12: S-Parameter Plot Settings
Note:

These two S-parameters are an example of the transmission and reflection for a
particular signal line (specifically, TXCLK_12). If represented according to the
associated lumped port numbers, the S-parameter designations would be S(6,5)
and S(6,6), which are the transmission and reflection results, respectively.

4. Click New Report and then Close.

Terminal S-Parameter Plot 1 appears in a new window:
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Terminal S Parameter Plot 1 HESSModlf Ansys
2023 R1
a
-10 A P
o0 4
= -30 71
- lll
- Il
10 it ——  dB(SHTXCLK_12_shall_T1 LNK_12_bwire_T1))
) ! Setupl ; Spectral
1 dB(SHTHCLK_12_shal_T1 LNK_12_shal_T1))
. Setupl : Spectral
50
_ED T T T T | T T T T | T T T T | T T T T | T T T
a 2 4 3] g 10
Freg [GHz]

Figure 4-13: S-Parameters vs. Frequency Plot

Observations:

¢ The transmission for the TXCLK_12 signal line (red curve) is approx-
imately 0 dB for DC conditions and tends to decrease with frequency until
a sharp decrease and minimal transmission result occurs at about
8.7 GHz. Beyond this frequency, the transmission increases again.

* The reflection for the TXCLK 12 signal line (green curve) is minimal at DC
conditions and tends to increase with frequency, though there is another
dip in reflection at about 2.3 GHz. Beyond about 3.6 GHz the reflection
curve flattens out and then declines slightly beyond 9 GHz.

5. H Save your project.
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You have completed the Ball Grid Array IC Package exercise. You can now save and close the
project.
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